69 Posts
Hey, I just wanted to render an image, but I have an issue: I see only the "Building scene..." message (for 10+ minutes now). Is there a way to stop it and try to restart the rendering? smiling face with open mouth
14 Jan 2018, 13:54
308 Posts
I have also had this problem and it has something to do with the Ubuntu server according to Scrubs! Don't know any way to abort this. Only frustrated that you can't do anything. I closed the browser and when I opened it again and switched to 3d rendering it was still counting the time. I changed models and the render button was greyed out while the other model was stuck in the building process.

Good to know it's more users who have the same issue!
14 Jan 2018, 14:42
Edited 14 Jan 2018, 14:44
69 Posts
Aaah, yes, you're right, I remember that Scrubs wrote something about the server on another topic. I guess the nodes didn't connect automatically again, so that's why they don't render my scene. Okay, thanks, I'll wait until Scrubs wakes up! ( Time zones.... smiling face with open mouth )
14 Jan 2018, 14:45
Edited 14 Jan 2018, 14:48
11 Posts
Same issue here.
I read this topic too late... XD

But I've just managed to stop the process in some way.
I've made a long click on the X of the "Building scene" bar and it stopped.
14 Jan 2018, 14:54
Edited 14 Jan 2018, 14:57
308 Posts
You don't have to worry about your credits anyway, this message is from Scrubs after my render had been stuck in building mode for 45 minutes.

"Unbuntu master server restarted without any warnings... Relaunched everything and backlog scenes have been built and rendered."

Then i could see that it had been rendered in 2 minutes and cost around 0.3 credits! smiling face with open mouth
14 Jan 2018, 16:29
2462 Posts
Hello,

I am in trouble with the server stability. It keeps doing some weird stuff and I cannot find the root cause as I am kinda new to Linux.

The "building scene" step is actually made of the sub steps:
1. Create project in the database - Apache server
2. Extract zip files - Apache server
3. Generate Blender scene - Python Server
4. Put in rendering queue - Python Server

The issue for now is that it looks like Linux is rebooting for some reasons I cannot find. Apache server is automatically relaunched so steps 1 and 2 are re-happening normally but it is blocked after as the python server needs to be relaunched manually.

As soon as I relaunch it, step 3 and 4 happen normally and the backlog is quickly cleared. Like Sealund said, it doesn't have any impact on credits as only rendering step is charged. Building the scene or compositing is not included in.
14 Jan 2018, 19:57
Edited 14 Jan 2018, 20:22
69 Posts
Hi, thank you for the answer, now it's clear and I hope you'll find a solution. Oh, what am I talking about? - I'm sure you'll find a solution. smiling face with open mouth After you relaunched the server, the render farm rendered my scene, so everything is OK right now!
14 Jan 2018, 20:04
Edited 14 Jan 2018, 20:04
130 Posts
I would anyway recommend to plan one "server reboot" per day for "maintenance" purposes.
15 Jan 2018, 09:28
2462 Posts
Looks like what I did had an impact. It has been running 15 hours non stop without any issues.
15 Jan 2018, 09:30
2462 Posts
Tried to add again the main server in the list of the worker and it crashed again last night. Will try with only the 5 other dedicated machines for a longer period of time to see if it is just that the master server cannot cope with rendering and doing server stuff (I kept a few CPU cores free for this task at the time).
15 Jan 2018, 18:38
15 Posts
I have the same problem now.

btw. how about adding a daemon that would monitor python and restart it when needed?
24 Jan 2018, 21:14
Edited 24 Jan 2018, 21:17
2462 Posts
Getting more stable nowadays but still a few issues. I cannot do anything right now. That will be solved when I get back home tonight.

This is not as simple as just restarting a script and that would be just a plaster. What when the machine freezes? I need to find the root cause which I will at some point face with stuck-out tongue
24 Jan 2018, 21:20
Edited 24 Jan 2018, 21:25
2 Posts
I know this is an old post, but it's the only relevant issue I can find. My moc has been going through Render for about 3 1/2 hours and I can't find a way to cancel the building process.
10 Mar 2018, 22:30
2462 Posts
The server is still crashing sometimes. I am currently away and cannot restart it now.
10 Mar 2018, 23:11
2 Posts
Thank you for fixing it!
11 Mar 2018, 14:39
2 Posts
Hi,

i'm new to Mecabricks, but i have this exact same issue. The rendering is now stuck for 48H. I can't cancel or delete the rendering process, and neither make a new rendering.

Is there a solution to reset the process? Or do I have to create a new account?

Thank you for your help.
25 Jun 2018, 15:02
11 Posts
Same problem here, but creating a new account doesn't solve it disappointed face
25 Jun 2018, 15:13
308 Posts
I think the renderfarm has crashed and to solve it usually @Scrubs have to reboot it. Not sure if he can do that now as i think he's away from home?
25 Jun 2018, 17:36
2462 Posts
Looks like it is a bug in the python code of the server app as the the server itself is still up. I cannot do anything until Tuesday next week.
Issues always happen when I am away. It did run smoothly without maintenance for more than a month before I left.
25 Jun 2018, 21:13
Edited 25 Jun 2018, 21:16
11 Posts
Ok, we'll wait until you solve the bug.
Thank you Scrubs!
25 Jun 2018, 21:16
Page 1 of 2