170 Posts
Hi,
First off, the new add-on version of the Blender script is a stroke of genius, but unfortuitously I am experiencing one slight issue…it is not working.
Actually, it is only the import process that is failing, sending some error messages and no bricks into the scene.
1. The first error message says that in init.py “Line 499, in execute return importMecabrick(Self, context, self.filepath)”

2. The second also says that in init.py “Line 168, in ImportMecabricks if bpy.app.version <=(2,78,0) and Useprincipled: NameError: name “use principled is not defined””

3. And the last little bit of text just states: “location: <unknown location>:-1” (Apparently computers have taking to using some sort of emoji in their reports? face with stuck-out tongue)

Looking at the error messages with my somewhat untrained software mind, the seemingly most obvious thing regards the ≤2.78.0...I am using Blender 2.78 and the newest iteration of the script—I have also uninstalled and reinstalled the script multiple times (completely deleting it from my downloads and from Blender’s add-on source folder) to no avail. Is there something that I am doing wrong; am I just using an “outdated” version of Blender; or is there some other reason? Confused face Also, is anyone else having this problem as well or is it just me overlooking the obvious?
Thanks in advance,
Qwerty7556
13 Jun 2017, 21:48
Edited 14 Jun 2017, 16:37
5 Posts
I use the 2.78 too. Same problem as I try to import the mad scientist quadcopter that was previosly exported as collada file, grouped by geometry and with lego logo activated.
14 Jun 2017, 05:54
1406 Posts
What operating system are you using. I tried macos and Windows and it is working fine. Are you using the production version of blender which is 2.78c (2.78.0) or a daily build?

Please use the code tag in the forum to put the code from the console. It is way easier to read.

@visionary. Don't use a model that has been exported a while ago. Re-export it again after clearing your browser cache.
14 Jun 2017, 09:45
Edited 14 Jun 2017, 09:46
170 Posts
I am using MacOS Sierra v10.12.3 and Blender v2.78c.
14 Jun 2017, 16:40
Edited 14 Jun 2017, 16:41
85 Posts
Have you re-downloaded the models you are importing? I also got a strange error message first time i tried an old model before re-downloading it.

Edit: Sorry didn´t read scrubs post...
14 Jun 2017, 19:51
Edited 14 Jun 2017, 19:52
1406 Posts
@Qwerty7556 Make sure that in the preferences, 'Use principle shader' is unticked. It shall not be possible to tick it anyway. 2.78c doesn't have this new shader. Where did you install it? There are two possible places for macos. It can be inside the blender package or in the App Support folder.

If you manually uninstall it , you need to remove the whole 'mecabricks' folder that includes __init__.py and a folder named materials.
14 Jun 2017, 20:26
Edited 14 Jun 2017, 20:30
1406 Posts
Ok, I think I found something in the code that could explain that. I will publish a new revision tonight that shall hopefully solve it.
14 Jun 2017, 20:32
1406 Posts
Download new version 2.0.2 it shall be fixed.
15 Jun 2017, 06:13
170 Posts
Yes, thank you, it is working perfectly now. smiling face with open mouth
15 Jun 2017, 16:10
Page 1 of 1