16 Posts
Is the workshop being updated? I can no longer import designs (LDD files) as I am getting a "500 error". Also, my previously saved templates (e.g.: floor, lightning, etc) are still available but the settings are reset and if I try to render one of my saved files, all parts are rendered with 1 color.
14 Jan 2020, 21:31
14 Posts
Exporting is completely broken as well. If you can actually get it to export, bringing it into 3D applications are broken geo, material connections, names, namespaces. Nothing works properly.
15 Jan 2020, 00:29
2946 Posts
The whole mecabricks platform has been updated today. You shall make sure that you cleared your browser cache to get the latest version of the code. The Blender add-one shall be downloaded as well.

If you think something is not working, please provide useful information to help fix it.
15 Jan 2020, 02:00
14 Posts
Do you have a copy of Maya that you could try pulling a .dae into? Cleared caches, redownloaded the zip, restart, deleted temps, same results. I dont have Blender to test in that software. Ill keep messing around with things but so far 3 for 3 on models coming in with all the networks haywire. Thanks for your time by the way!
15 Jan 2020, 03:47
16 Posts
Ok, so 2 problems, let me know what other information you may need:

1) it seems a problem in importing .LXF files as I can no longer import them (getting Error 500). I have tried a .LDR file and was able to import it though.

2) the rendered model is coming up with "gray" pieces, no color, etc. I can't post a picture here to show it though but I am sure that scrubs can see my last renders. As a test, I have changed the material of certain pieces (tires) to rubber, and that was rendered correctly, but solid colors are still coming as gray even after changing them. Am I missing a new setting/switch?
The same files worked before, so nothing changed on my end.

I have kept trying and the last test had only one part (the same piece design) correctly colored in the model, but everything else was gray.

Thanks.
15 Jan 2020, 04:06
Edited 15 Jan 2020, 05:15
3 Posts
nvm
15 Jan 2020, 05:48
Edited 15 Jan 2020, 05:48
16 Posts
It seems .lxf files can't be imported when they have part groups. Models without groups are imported corretly. Also there is something weird with normals of 1x8 tile in workshop.
15 Jan 2020, 12:36
16 Posts
Thanks Sunder_59, I will try that out. Are you able to render your models correctly by removing the groups?
15 Jan 2020, 13:09
16 Posts
Ok, so here are some screenshots to show what is happening, trying to provide as much information as possible. Removing all the groups from the .LXF file allows me to import it now, but render still does not work.

https://www.amazon.com/clouddrive/share/rXBEDPclbA4G4OBdG9fx3fKPRzJpa9PGsu5SVSizvyA

I have put together the different tests I did, the render works for models built using the workshop, but I can't render imported models built in Stud.io or LDD as the parts have no color/texture. Even after I replace the color the problem remains (even though last night it worked on rubber, today it did not).

Scrubs let me know if you need anything else on this.

Thanks.
15 Jan 2020, 14:25
2946 Posts
I will slowly go through all of this. Most of them are small bugs. Is the problem un the online render mode or Blender?
15 Jan 2020, 18:17
16 Posts
Thanks. The problem is with the workshop (online).
15 Jan 2020, 18:52
2946 Posts
Issue with incorrect material for imported model is fixed.
15 Jan 2020, 22:40
16 Posts
Perfect again, thank you very much!
16 Jan 2020, 01:35
2946 Posts
LDD/LDraw importers are fixed
16 Jan 2020, 01:37
Edited 16 Jan 2020, 01:37
16 Posts
Thanks!
Now, one issue that I found is that whenever I save a project in the workshop (with HDRI settings, floor, etc), once I open it, the settings are gone (reset). The model is saved, but the settings are not.
16 Jan 2020, 17:01
2946 Posts
Ok I'll check.
16 Jan 2020, 18:21
2946 Posts
Thank you for reporting it. It is fixed and render settings are properly loaded now - (You may have to clear your cache to get the update).
16 Jan 2020, 19:34
16 Posts
Once again, thank you! all good now!
16 Jan 2020, 20:05
Page 1 of 1