24 Posts
If I use HDRI lighting in the workshop and turn on "activate custom lamps" all of the lighting goes dark. When the box is unchecked, the HDRI lighting comes back but of course it is missing the custom lamps.

In the render preview viewport, everything is staying dark regardless of whether HDRI is being used or not.

Thank you, Finn
15 Jan 2019, 16:43
253 Posts
I had the same problem with a model where I added lights before this function was enabled. Try to delete the lights and replace them with the same type, it worked for me. Maybe there something in the new code that doesn't work with "old" lights?
15 Jan 2019, 18:56
2153 Posts
This is consistent as the rendering mode activates the lamps.
Does everything turn black even if no lamps are in the scene? Does this issue only happen with certain types of lamp or all of them? What operating system and browser do you use?
15 Jan 2019, 19:12
24 Posts
The cache dump and replacing the lights (emphasis on the latter) fixed the issue, thank you!
17 Jan 2019, 02:55
2153 Posts
I can confirm that there are issues with lamps added before the last big update which causes the models not being able to be built in the render farm as well as breaking the "activate custom lamps" option in the viewport .
I cannot see any easy fix for that. It is a pile of bugs that lead to this. Maybe we can just live with the fact that old lamps must be fixed?
17 Jan 2019, 04:41
2153 Posts
No more issues. I fixed everything. I rewrote the code and included some converters for the old lamps. You may just have to update the strength values in some cases.
17 Jan 2019, 22:32
Page 1 of 1