12 Posts
This is one of my very first robots i've build with LEGO.
It is imported in Blender EEVEE via Mecabricks plugin and render with the new 2.8 engine.



Second video here: https://youtu.be/2pmo_gkZVfY

Last video:



If you are in the mech business, you may look at my:

Flickr: https://www.flickr.com/people/controlaltbrick/

Most of the images are Mecabricks + Blender renders
19 Nov 2018, 09:45
Edited 30 Dec 2018, 17:32
3053 Posts
I saw your other images on flickr but I missed the video.
Result is pretty good especially with 60fps. How long did it take per frame to render?
20 Nov 2018, 03:28
12 Posts
It average 3.6 seconds per frame (3 hours for 3000 frames) on a gtx 1080.
128 samples and 64 motion blur samples (i prolly used too many samples)

The recent Blender builds fixed most of the problems with group nodes; there are still problems when you enable subsurface scattering (you need to put node "constant values" on the shaders and ungroup the first level, to make it work)

I also had to scale the model to 1/10 and fix shaders, to get decent shadows (i'm using a sun light, shadows are not working directly from the hdr back)

Motion blur seems also abit bugged; i had to lower the shutter to 0.5, or there was too much ghosting (the motion blur is still excessive and blur too much even when the motion is slow).

Overall alot of glitches but a good result i think, we can render a full movie (1/2 hours) at home in few days, it is quite amazing
20 Nov 2018, 08:24
88 Posts
Hi,

Nice video ! The result is really cool !

A recent commit (https://developer.blender.org/rB68b670698fc) from Clément Foucault (main EEVEE developer) announced that problems related to the SSS with Principled BSDF in Node Groups have been fixed. However, I still have problems with SSS when I use EEVEE. Even when I use Node Value. And Linked Materials do not work at all. Hope they'll fix this.
20 Nov 2018, 11:53
12 Posts
Thanks for the info i'll go to check out.

Atm i'm using 15 nov. build; the lite plugin work out of the box for me.

I have problems with the advanced plugin and SSS, it seems related to nested groups and solved by ungrouping the 1st level: a series of node values (for the various dirt/fingerprints etc. parameters) and an RGB node for the color is needed before ungrouping, or you lose the values (this have to be done for each material, blender ungrouping sucks!).
I tested this with real geometry (so no shader bevel) and simple materials (there are no transparent nor textured pieces).
20 Nov 2018, 13:05
12 Posts
@Helo: Testing today build, seems all the groups problems are fixed for me!
22 Nov 2018, 16:44
88 Posts
@ControlAltBrick: Arf... Still have problems. Especially when I both enable "Subsurface Scattering" and "Refraction" option in "Screen Space Reflections" Panel. "Beta" should be released this week. Maybe it will be fixed.
27 Nov 2018, 10:53
12 Posts
LEGO Castle Explosion:

https://youtu.be/2pmo_gkZVfY

Be sure to set 1080p (and watch it on a big screen xD)!

This is my first attempt with Blender 2.80 + physics animation.
The castle is around 5000 pieces, the render took 11 hours - 1 frame every 17 seconds (256 samples).

I managed to get shadows working with no model rescaling: you have to play with clip values (also in the cascaded shadow map if you use a sun light).
Shadows are still abit glitched and i was not able to obtain soft shadows (i guess i have to scale down to 1/10 for that).

Also baked physics is bugged in EEVEE, i was getting glitches in the final render, to solve this you can:

- Do a viewport render (here samples seems hardcoded to a low value, the final result suffer aliasing)

or

- Go back to 2.79 and bake physics to keyframes (ended in the night, took between 7-15 hours for 5000 objects and 2430 frames!)

I've an internal 4k render nearly done... can't wait to watch it on my TV xD (4k, 128 samples takes 22 seconds per frame!)

PS: [youtube] tag does not work for this video (maybe the underscore?)
1 Dec 2018, 10:57
Edited 1 Dec 2018, 11:32
12 Posts
I got a new video up, this time build instructions




https://youtu.be/kOj8YYH7Yug

Very time consuming, but the result is very cool (i hope
)

Happy new year!
30 Dec 2018, 17:30
Edited 30 Dec 2018, 17:38
8 Posts
this looks awesome
what i am doing wrong with evee? my render looks very unrealistic with evee. which settings do i need pls ?
12 Apr 2020, 14:42
54 Posts
Do you have the Mecabricks plugin?
24 Apr 2020, 10:06
Page 1 of 1